package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]{1,7}+(?:[A-Z]\d?)?$`)
var str = `S3
FT5
FGTU7
ERTYUOP9
ERTGHYUKM
Correspond to:
E
ERT
RTYUKL
VBNDEFRW3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}