const regex = /refId=Id-(?<refID>[^\\]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('refId=Id-(?<refID>[^\\\\]+)', 'gm')
const str = `refId=Id-214f1652024d824e1f4cef63be666139\\x00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}