$re = '/refId=Id-(?<refID>[^\\\\]+)/m';
$str = 'refId=Id-214f1652024d824e1f4cef63be666139\\x00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);