// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)refId=Id-(?<refID>[^\\]+)").unwrap();
let string = "refId=Id-214f1652024d824e1f4cef63be666139\\x00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}