using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\-)(?:(?:[a-zA-Z\d][a-zA-Z\d\-]{0,61})?[a-zA-Z\d]\.){1,126}(?!\d+)[a-zA-Z\d]{1,63}$";
string input = @"invalid-.domains
-domain.com
domain--.com
-domain-.-.com
domain.000
.domain.net
domain.net.
sub.-domain.com
sub.domain-.com
sub-.domain.com
-sub.domain.com
valid.domains.below
schools.k12
newTLD.clothing
good.photography
x.a-b.com
x-y.a-b.net
x-y.a-b-c.co.uk
x.0ac.com
schools.k12
newTLD.clothing
good.photography
0-1-2.3-4.co
a-----b.com
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}