use strict;
my $str = 'invalid-.domains
-domain.com
domain--.com
-domain-.-.com
domain.000
.domain.net
domain.net.
sub.-domain.com
sub.domain-.com
sub-.domain.com
-sub.domain.com
valid.domains.below
schools.k12
newTLD.clothing
good.photography
x.a-b.com
x-y.a-b.net
x-y.a-b-c.co.uk
x.0ac.com
schools.k12
newTLD.clothing
good.photography
0-1-2.3-4.co
a-----b.com
';
my $regex = qr/^(?!\-)(?:(?:[a-zA-Z\d][a-zA-Z\d\-]{0,61})?[a-zA-Z\d]\.){1,126}(?!\d+)[a-zA-Z\d]{1,63}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}