using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!\bi+\b)\b[dcmlxvi]+\b|(\bi+\.)";
string input = @"i ii. Both ix is i i. ii. i viii are roman numeral. mcmlxxxvii is wow year. Year is mmxvi. i.";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}