$re = '/(?!\bi+\b)\b[dcmlxvi]+\b|(\bi+\.)/i';
$str = 'i ii. Both ix is i i. ii. i viii are roman numeral. mcmlxxxvii is wow year. Year is mmxvi. i.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);