use strict;
my $str = 'i ii. Both ix is i i. ii. i viii are roman numeral. mcmlxxxvii is wow year. Year is mmxvi. i.';
my $regex = qr/(?!\bi+\b)\b[dcmlxvi]+\b|(\bi+\.)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}