using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!"")""(?!\ )([^""\r]+)""(?!"")(*SKIP)(*F)|(?<!"")""\ ([^""\r]+)""(?!"")";
string input = @"The sign said, ""Walk."" Then it said, ""Don't Walk"", then, ""Walk"", all within thirty seconds. He yelled, ""Hurry up.""
"" text""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}