re = /(?<!")"(?!\ )([^"\r]+)"(?!")(*SKIP)(*F)|(?<!")"\ ([^"\r]+)"(?!")/m
str = 'The sign said, "Walk." Then it said, "Don\'t Walk", then, "Walk", all within thirty seconds. He yelled, "Hurry up."
" text"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end