$re = '/(?<!")"(?!\ )([^"\r]+)"(?!")(*SKIP)(*F)|(?<!")"\ ([^"\r]+)"(?!")/m';
$str = 'The sign said, "Walk." Then it said, "Don\'t Walk", then, "Walk", all within thirty seconds. He yelled, "Hurry up."
" text"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);