#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\(?(\d{3}\)?)[-.](\d{3})[\-\.](\d{4})"
Local $sString = "903-455-2346" & @CRLF & _
"(657)-878-9065" & @CRLF & _
"234.345.5676" & @CRLF & _
"(657)-878-9065"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")