$re = '/\(?(\d{3}\)?)[-.](\d{3})[\-\.](\d{4})/m';
$str = '903-455-2346
(657)-878-9065
234.345.5676
(657)-878-9065';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);