re = /\(?(\d{3}\)?)[-.](\d{3})[\-\.](\d{4})/m
str = '903-455-2346
(657)-878-9065
234.345.5676
(657)-878-9065'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end