package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^[^:]*((array|unassigned)*)[^:]*\n$`)
var str = `Smart Array P822 in Slot 2
array A
array B
array C
SmartCache array D
Drive Authentication Status: Not Authenticated. Smart Array will not control drive LEDs.
array E
unassigned
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}