$re = '/^[^:]*((array|unassigned)*)[^:]*\n$/im';
$str = 'Smart Array P822 in Slot 2
array A
array B
array C
SmartCache array D
Drive Authentication Status: Not Authenticated. Smart Array will not control drive LEDs.
array E
unassigned
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);