import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^:]*((array|unassigned)*)[^:]*\\n$";
final String string = "Smart Array P822 in Slot 2\n"
+ " array A\n"
+ " array B\n"
+ " array C\n"
+ " SmartCache array D\n"
+ " Drive Authentication Status: Not Authenticated. Smart Array will not control drive LEDs.\n"
+ " array E\n"
+ " unassigned\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}