use strict;
my $str = '<AbstractText/>blahThe aim of this investigation was to determine the molecular properties and provide an interpretation of the vibrational mode couplings of these two paracetamol analogues: 2-bromo-2-methyl-N-(4-nitrophenyl)-propanamide and 2-bromo-2-methyl-N-p-tolyl-propanamide. E/Z isomers, keto/enol unimolecular rearrangement and prediction of the transition state structures in each mechanism were also assessed using the Density Functional Theory (DFT). The DFT estimates a high energy gap between E and Z isomers (9-11 kcal·mol(-1)), with barrier heights ranging from 16 to 19 kcal·mol(-1). In contrast, the barrier energies on the keto/enol isomerization are almost 10 kcal·mol(-1) higher than those estimated for the E/Z rearrangement. The kinetic rate constant was also determined for each reaction mechanism. Natural bond orbital analysis and the quantum theory of atoms in molecules were used to interpret the intramolecular hydrogen bonds and to understand the most important interactions that govern the stabilization of each isomer. Furthermore, an analysis of the atomic charge distribution using different population methodologies was also performed.</AbstractText>';
my $regex = qr`(?s)<AbstractText\b[^>]*\b[^\/]?>(.+?)</AbstractText>`p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}