const regex = /^.*([A-Za-z0-9]{24}).*$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*([A-Za-z0-9]{24}).*$', 'gim')
const str = `/v1/api2/5eb98050122d484001708a11f
/v1/api1/5eb98050122d484001708a11f/61b3330151e541232146bfb7/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}