re = /^.*([A-Za-z0-9]{24}).*$/im
str = '/v1/api2/5eb98050122d484001708a11f
/v1/api1/5eb98050122d484001708a11f/61b3330151e541232146bfb7/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end