import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:[\\s\\,\\>]+|\\b)(?:(?:(Passport|PASSI-PASS|PASSI|PASS|PASSEPORT|passaporto)\\s*(?:Number|No\\.*|#|ID)*))(?:[\\s\\,\\<\\.]+|\\b))((?:[\\s\\,\\>]+|\\b)(?:[A-Za-z]{2}[0-9]{7})(?:[\\s\\,\\<\\.]+|\\b))\n"
+ "|(?:[\\s\\,\\>]+|\\b)((?:[A-Za-z]{2}[0-9]{7})(?:[\\s\\,\\<\\.]+|\\b))(?:(?:[\\s\\,\\>]+|\\b)(?:(?:(Passport|PASSI-PASS|PASSI|PASS|PASSEPORT|passaporto)\\s*(?:Number|No\\.*|#|ID)*))(?:[\\s\\,\\<\\.]+|\\b))";
final String string = "er3442156 ddaf\n"
+ " df8998098 dfada\n"
+ "JH6752034 passport \n"
+ "passaporto YU7845329\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}