import re
regex = re.compile((r"(?:(?:[\s\,\>]+|\b)(?:(?:(Passport|PASSI-PASS|PASSI|PASS|PASSEPORT|passaporto)\s*(?:Number|No\.*|#|ID)*))(?:[\s\,\<\.]+|\b))((?:[\s\,\>]+|\b)(?:[A-Za-z]{2}[0-9]{7})(?:[\s\,\<\.]+|\b))\n"
r"|(?:[\s\,\>]+|\b)((?:[A-Za-z]{2}[0-9]{7})(?:[\s\,\<\.]+|\b))(?:(?:[\s\,\>]+|\b)(?:(?:(Passport|PASSI-PASS|PASSI|PASS|PASSEPORT|passaporto)\s*(?:Number|No\.*|#|ID)*))(?:[\s\,\<\.]+|\b))"), flags=re.IGNORECASE)
test_str = ("er3442156 ddaf\n"
" df8998098 dfada\n"
"JH6752034 passport \n"
"passaporto YU7845329\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")