#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:3[01]|[12][0-9]|0?[1-9])$"
Local $sString = "31" & @CRLF & _
"1" & @CRLF & _
"01" & @CRLF & _
"19" & @CRLF & _
"22" & @CRLF & _
"0" & @CRLF & _
"00" & @CRLF & _
"32"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")