package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:3[01]|[12][0-9]|0?[1-9])$`)
var str = `31
1
01
19
22
0
00
32`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}