$re = '/^(?:3[01]|[12][0-9]|0?[1-9])$/m';
$str = '31
1
01
19
22
0
00
32';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);