# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*(\d+),[^,]*$/$1/gm;t' <<< "0, 2, 3
1, 3, 6, 8
8, 4
9, 3, 5, 3, 7"