const regex = /^.*(\d+),[^,]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*(\\d+),[^,]*$', 'gm')
const str = `0, 2, 3
1, 3, 6, 8
8, 4
9, 3, 5, 3, 7`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);