import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\})[\\s]*?\\{.*?\\}";
final String string = "{\n"
+ "color: red\n"
+ "}\n\n"
+ "a\n"
+ "{\n"
+ "color: red\n"
+ "} {\n"
+ "color: red\n"
+ "}\n\n"
+ "{\n"
+ "color: red\n"
+ "}\n\n"
+ "a\n"
+ " {\n"
+ "color: red\n"
+ "}\n\n"
+ "{\n"
+ "color: red\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}