re = /(?<=\})[\s]*?\{.*?\}/im
str = '{
color: red
}
a
{
color: red
} {
color: red
}
{
color: red
}
a
{
color: red
}
{
color: red
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end