$re = '/((\s,|,|,\s)span)|(span(\s,|,|,\s))/';
$str = '
div, .span[href="#"], a{
color: red;
}
.span[href="#"],div{
color: red;
}
.span, span, div{
wdad
}
a, div, span{
wdad
}
a, span, div {
wdad
}
span, span, div {
wdad
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);