import Foundation
let pattern = #"((\s,|,|,\s)span)|(span(\s,|,|,\s))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
div, .span[href="#"], a{
color: red;
}
.span[href="#"],div{
color: red;
}
.span, span, div{
wdad
}
a, div, span{
wdad
}
a, span, div {
wdad
}
span, span, div {
wdad
}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)