// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((\s,|,|,\s)span)|(span(\s,|,|,\s))").unwrap();
let string = "
div, .span[href=\"#\"], a{
color: red;
}
.span[href=\"#\"],div{
color: red;
}
.span, span, div{
wdad
}
a, div, span{
wdad
}
a, span, div {
wdad
}
span, span, div {
wdad
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}