using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^X0\d+\s+\w+\s*(?P<PARAM_1>\d+(?:\.\d+)?)\s+(?P<PARAM_2>\d+(?:\.\d+)?)\s+(?P<PARAM_3>\d+(?:\.\d+)?)";
string input = @"# control.dat
X001 A3 100.0 20.0 40.0
A5 124.0
I3 125.0
X002 C3 200.054 20.494 45.0
C5 122.0
K3 122.01
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}