const regex = new RegExp('^X0\\d+\\s+\\w+\\s*(?P<PARAM_1>\\d+(?:\\.\\d+)?)\\s+(?P<PARAM_2>\\d+(?:\\.\\d+)?)\\s+(?P<PARAM_3>\\d+(?:\\.\\d+)?)', 'gm')
const str = `# control.dat
X001 A3 100.0 20.0 40.0
A5 124.0
I3 125.0
X002 C3 200.054 20.494 45.0
C5 122.0
K3 122.01
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}