$re = '/^X0\d+\s+\w+\s*(?P<PARAM_1>\d+(?:\.\d+)?)\s+(?P<PARAM_2>\d+(?:\.\d+)?)\s+(?P<PARAM_3>\d+(?:\.\d+)?)/m';
$str = '# control.dat
X001 A3 100.0 20.0 40.0
A5 124.0
I3 125.0
X002 C3 200.054 20.494 45.0
C5 122.0
K3 122.01
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);