using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-3][0-9][0-1][1-9][0-9]{2}[-\s][0-9]{4}$";
string input = @"WANT THIS:
100282 1187
100282-1187
NOT THIS:
1002821187
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}