package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-3][0-9][0-1][1-9][0-9]{2}[-\s][0-9]{4}$`)
var str = `WANT THIS:
100282 1187
100282-1187
NOT THIS:
1002821187
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}