#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?=[a-zA-Z]*e)(?=[a-zA-Z]*(.)\1)[a-zA-Z]+\b"
Local $sString = "It’s not artificial intelligence it’s a charismatic mistake machine. Specific LLMs and neural networks can be trained to be really good at pre-defined tasks, but in general they are only really good at doing tasks that have already been done 300 million times, and terrible at new and novel tasks. Any time there’s limited training data it either plagiarizes or is totally wrong." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")