import re
regex = re.compile(r"\b(?=[a-zA-Z]*e)(?=[a-zA-Z]*(.)\1)[a-zA-Z]+\b", flags=re.MULTILINE)
test_str = ("It’s not artificial intelligence it’s a charismatic mistake machine. Specific LLMs and neural networks can be trained to be really good at pre-defined tasks, but in general they are only really good at doing tasks that have already been done 300 million times, and terrible at new and novel tasks. Any time there’s limited training data it either plagiarizes or is totally wrong.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")