$re = '/\b(?=[a-zA-Z]*e)(?=[a-zA-Z]*(.)\1)[a-zA-Z]+\b/m';
$str = 'It’s not artificial intelligence it’s a charismatic mistake machine. Specific LLMs and neural networks can be trained to be really good at pre-defined tasks, but in general they are only really good at doing tasks that have already been done 300 million times, and terrible at new and novel tasks. Any time there’s limited training data it either plagiarizes or is totally wrong.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);