package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\()?((\d+|\((?2)\))([+*](\d+|\((?2)\)))+)(?(1)\))=\d+$`)
var str = `(1+1)+1*1+(1*1)+(1*(123+1))=1
(2+3)*7=5
12*1+A=2
12*1-2=2
12*1+2=2
12*+1+2=2
(12*1+2=2
12*1+2)=2
((12*1)+2)=2
((12*1+2)=2
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}