$re = '/^(\()?((\d+|\((?2)\))([+*](\d+|\((?2)\)))+)(?(1)\))=\d+$/xm';
$str = '(1+1)+1*1+(1*1)+(1*(123+1))=1
(2+3)*7=5
12*1+A=2
12*1-2=2
12*1+2=2
12*+1+2=2
(12*1+2=2
12*1+2)=2
((12*1)+2)=2
((12*1+2)=2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);