import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\()?((\\d+|\\((?2)\\))([+*](\\d+|\\((?2)\\)))+)(?(1)\\))=\\d+$";
final String string = "(1+1)+1*1+(1*1)+(1*(123+1))=1\n"
+ "(2+3)*7=5\n"
+ "12*1+A=2\n"
+ "12*1-2=2\n"
+ "12*1+2=2\n"
+ "12*+1+2=2\n"
+ "(12*1+2=2\n"
+ "12*1+2)=2\n"
+ "((12*1)+2)=2\n"
+ "((12*1+2)=2\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}