using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d)(?:px|em|%|vh|s)$";
string substitution = @"$1";
string input = @"432px
or 432em
or 432%
or 432vh
or 432s
foobar
embedded";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}