// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d)(?:px|em|%|vh|s)$").unwrap();
let string = "432px
or 432em
or 432%
or 432vh
or 432s
foobar
embedded";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}