const regex = /(\d)(?:px|em|%|vh|s)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d)(?:px|em|%|vh|s)$', 'gm')
const str = `432px
or 432em
or 432%
or 432vh
or 432s
foobar
embedded`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);