package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)((?:\d+(?:,\d+)?[xх]?)+)`)
var str = `ВВГНГ(А) 3x2,5 *
ВВГНГ(А) 3х2,5x10 * CFD`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}