$re = '/((?:\d+(?:,\d+)?[xх]?)+)/i';
$str = 'ВВГНГ(А) 3x2,5 *
ВВГНГ(А) 3х2,5x10 * CFD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);