// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)((?:\d+(?:,\d+)?[xх]?)+)").unwrap();
let string = "ВВГНГ(А) 3x2,5 *
ВВГНГ(А) 3х2,5x10 * CFD";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}